summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2024-12-20 21:56:30 +0100
committerLeo Famulari <[email protected]>2025-01-16 20:43:51 -0500
commit0b06a5bc97938cae3da19e566c2f6f71cc299d78 (patch)
tree4a175cb1611609639e9166142fdd46169de1bf86
parentad9a2f9643358d19c212becf53ae59f6a1287125 (diff)
gnu: python-pydevd: Avoid test failures due to greendns.
* gnu/packages/python-xyz.scm (python-pydevd)[arguments]: Disable one stubborn test; set EVENTLET_NO_GREENDNS. Change-Id: I3cf5af6c99dbb18095277f353f46c60f68a62188
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1b4bd7221f..93caeae282 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17830,7 +17830,8 @@ libmagic.")))
;; of the build file name present in the message.
"and not test_evaluate_exception_trace "
;; This test fail with TimeoutError, no message on stderr.
- "and not test_soft_terminate "))
+ "and not test_soft_terminate "
+ "and not test_debugger_case_deadlock_interrupt_thread"))
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'fix-tests
@@ -17872,6 +17873,9 @@ libmagic.")))
(add-before 'check 'pre-check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
+ ;; Without this we get this error: type object 'GreenSocket'
+ ;; has no attribute 'sendmsg'.
+ (setenv "EVENTLET_NO_GREENDNS" "YES")
(setenv "PYDEVD_USE_CYTHON" "YES"))))
(add-after 'install 'install-attach-binary
(lambda _