From 0b06a5bc97938cae3da19e566c2f6f71cc299d78 Mon Sep 17 00:00:00 2001
From: Ricardo Wurmus <rekado@elephly.net>
Date: Fri, 20 Dec 2024 21:56:30 +0100
Subject: gnu: python-pydevd: Avoid test failures due to greendns.

* gnu/packages/python-xyz.scm (python-pydevd)[arguments]: Disable one stubborn
test; set EVENTLET_NO_GREENDNS.

Change-Id: I3cf5af6c99dbb18095277f353f46c60f68a62188
---
 gnu/packages/python-xyz.scm | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1b4bd7221f..93caeae282 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17830,7 +17830,8 @@ (define-public python-pydevd
                ;; of the build file name present in the message.
                "and not test_evaluate_exception_trace "
                ;; This test fail with TimeoutError, no message on stderr.
-               "and not test_soft_terminate "))
+               "and not test_soft_terminate "
+               "and not test_debugger_case_deadlock_interrupt_thread"))
       #:phases
       #~(modify-phases %standard-phases
           (add-after 'unpack 'fix-tests
@@ -17872,6 +17873,9 @@ (define-public python-pydevd
           (add-before 'check 'pre-check
             (lambda* (#:key tests? #:allow-other-keys)
               (when tests?
+                ;; Without this we get this error: type object 'GreenSocket'
+                ;; has no attribute 'sendmsg'.
+                (setenv "EVENTLET_NO_GREENDNS" "YES")
                 (setenv "PYDEVD_USE_CYTHON" "YES"))))
           (add-after 'install 'install-attach-binary
             (lambda _
-- 
cgit v1.2.3