summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2024-12-20 21:55:25 +0100
committerLeo Famulari <[email protected]>2025-01-16 20:43:44 -0500
commitad9a2f9643358d19c212becf53ae59f6a1287125 (patch)
treeefd0664d4d6e1d9c37eb019f64b7d19d930ad54c
parente902f73f6043cd857e58b4ee78e8d22f5c6d2aba (diff)
gnu: python-pydevd: Disable flaky tests.
Setting IS_PYPY doesn't do anything and I only set it before due to a misunderstanding. Instead we should disable flaky tests. * gnu/packages/python-xyz.scm (python-pydevd)[arguments]: Ignore tests marked as "flaky"; do not set IS_PYPY variable in 'pre-check phase. Change-Id: If28f3dfd533df9048aeee5ecd42984b40ea0a22a
-rw-r--r--gnu/packages/python-xyz.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 62af6ad2b1..1b4bd7221f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17816,6 +17816,7 @@ libmagic.")))
(list
#:test-flags
#~(list "-n" (number->string (parallel-job-count))
+ "-m" "not flaky"
"-k"
(string-append
;; The two "break_01" tests have been failing on