summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2025-01-02 15:36:40 +0100
committerRicardo Wurmus <[email protected]>2025-01-20 21:37:30 +0100
commit9c9eba6babf9dc5416714fe82e6f44ec9e148437 (patch)
tree646e63380fd3d83b7552df05304fda2cc59607f1
parent2b8bbc9cbcebf5c5dd9b9885fb97f095ff59783b (diff)
gnu: python-black: Limit number of test processes.
* gnu/packages/python-xyz.scm (python-black)[arguments]: Do not exceed 8 parallel jobs when running tests. [native-inputs]: Add python-pytest-xdist. Change-Id: Ifa0ab22e6b5c6ba3fdc588ae6a25ca4ad410936b
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 605e308226..4fb16fcd27 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8799,8 +8799,13 @@ and integrated feature-set for programming Python effectively.")
"0xa8vkgbvmkdh4vsk967xh81i6g47fcqf5vngdkvrqxgjx6acvl4"))))
(build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
+ (list
+ #:test-flags
+ ;; On the build farm we run out of resources if we let the build system
+ ;; autodetect the number of parallel processes.
+ '(list "--numprocesses" (number->string (min (parallel-job-count) 8)))
+ #:phases
+ '(modify-phases %standard-phases
(add-after 'patch-source-shebangs 'use-absolute-file-names
(lambda* (#:key inputs #:allow-other-keys)
(substitute* (find-files "tests" "\\.py$")
@@ -8818,6 +8823,7 @@ and integrated feature-set for programming Python effectively.")
(native-inputs
(list python-pytest
python-pytest-aiohttp
+ python-pytest-xdist
python-hatch-fancy-pypi-readme
python-hatch-vcs
python-hatchling))