summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 605e308226..4fb16fcd27 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8799,8 +8799,13 @@ and integrated feature-set for programming Python effectively.")
"0xa8vkgbvmkdh4vsk967xh81i6g47fcqf5vngdkvrqxgjx6acvl4"))))
(build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
+ (list
+ #:test-flags
+ ;; On the build farm we run out of resources if we let the build system
+ ;; autodetect the number of parallel processes.
+ '(list "--numprocesses" (number->string (min (parallel-job-count) 8)))
+ #:phases
+ '(modify-phases %standard-phases
(add-after 'patch-source-shebangs 'use-absolute-file-names
(lambda* (#:key inputs #:allow-other-keys)
(substitute* (find-files "tests" "\\.py$")
@@ -8818,6 +8823,7 @@ and integrated feature-set for programming Python effectively.")
(native-inputs
(list python-pytest
python-pytest-aiohttp
+ python-pytest-xdist
python-hatch-fancy-pypi-readme
python-hatch-vcs
python-hatchling))