summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2025-01-02 13:37:52 +0100
committerRicardo Wurmus <[email protected]>2025-01-20 21:37:30 +0100
commit2b8bbc9cbcebf5c5dd9b9885fb97f095ff59783b (patch)
tree4c221732815572233f9b690a0c6a33d5b61665cf
parentaeffe24fd9f3fcd1f28b3ca2faf2a8fb4b6aaee2 (diff)
gnu: python-black: Update to 24.10.0.
* gnu/packages/python-xyz.scm (python-black): Update to 24.10.0. [propagated-inputs]: Remove python-attrs, python-appdirs, python-regex, and python-typed-ast. [native-inputs]: Remove python-setuptools, python-setuptools-scm, and python-wheel; add python-hatch-fancy-pypi-readme, python-hatch-vcs, and python-hatchling. Change-Id: Idf0d6ae54cc29a0652144be6adbce329aac6e81f
-rw-r--r--gnu/packages/python-xyz.scm17
1 files changed, 7 insertions, 10 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cd7cf53c9b..605e308226 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8789,14 +8789,14 @@ and integrated feature-set for programming Python effectively.")
(define-public python-black
(package
(name "python-black")
- (version "22.3.0")
+ (version "24.10.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "black" version))
(sha256
(base32
- "0yfahlqc7dsdp1js0cbv706apldnfnlbal9b53cww8n0hs40n0im"))))
+ "0xa8vkgbvmkdh4vsk967xh81i6g47fcqf5vngdkvrqxgjx6acvl4"))))
(build-system pyproject-build-system)
(arguments
`(#:phases
@@ -8809,21 +8809,18 @@ and integrated feature-set for programming Python effectively.")
"#!" (search-input-file inputs "/bin/python3")))))))))
(propagated-inputs
(list python-click
- python-attrs
- python-appdirs
- python-pathspec
python-mypy-extensions
+ python-packaging
+ python-pathspec
python-platformdirs
- python-regex
python-tomli
- python-typed-ast
python-typing-extensions))
(native-inputs
(list python-pytest
python-pytest-aiohttp
- python-setuptools
- python-setuptools-scm
- python-wheel))
+ python-hatch-fancy-pypi-readme
+ python-hatch-vcs
+ python-hatchling))
(home-page "https://github.com/psf/black")
(synopsis "The uncompromising code formatter")
(description "Black is the uncompromising Python code formatter.")