summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/julia-xyz.scm24
1 files changed, 23 insertions, 1 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 03621a94c7..a6a4eabd6f 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2021 Vinicius Monego <[email protected]>
;;; Copyright © 2021 jgart <[email protected]>
;;; Copyright © 2023 Sharlatan Hellseher <[email protected]>
-;;; Copyright © 2024 Spencer King <[email protected]>
+;;; Copyright © 2024, 2025 Spencer King <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1466,6 +1466,28 @@ perform optimization and therefore ideal for computer vision applications such
as SLAM (simultaneous localization and mapping).")
(license license:expat))))
+(define-public julia-cpuid
+ (package
+ (name "julia-cpuid")
+ (version "0.3.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/m-j-w/CpuId.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0x2csy8cvd1rm49qpqpkb3zs7swj4r91zdsyjafqr7hvjp9h3hjz"))))
+ (build-system julia-build-system)
+ (propagated-inputs (list julia-precompiletools))
+ (home-page "https://github.com/m-j-w/CpuId.jl")
+ (synopsis "Ask the CPU for its features and specifications")
+ (description
+ "This package allows you to query the availability of specific
+CPU features with low run-time cost.")
+ (license license:expat)))
+
(define-public julia-crayons
(package
(name "julia-crayons")