summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSpencer King <[email protected]>2025-01-02 19:54:48 +0000
committerLudovic Courtès <[email protected]>2025-01-06 16:24:46 +0100
commite2d0eba13cdb1de2d7209da0e70f149ff166eb0f (patch)
treea56ed4de07d591f8f33cbde95bce621775e63a7c
parentaf6224359f1b698d0518ce42dc5eeafa7e081c91 (diff)
gnu: Add julia-cpuid.
* gnu/packages/julia-xyz.scm (julia-cpuid): New variable. Change-Id: Ifd9abfb142184c58941c97e959a4b5c9247ce1a8 Signed-off-by: Ludovic Courtès <[email protected]>
-rw-r--r--gnu/packages/julia-xyz.scm24
1 files changed, 23 insertions, 1 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 03621a94c7..a6a4eabd6f 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2021 Vinicius Monego <[email protected]>
;;; Copyright © 2021 jgart <[email protected]>
;;; Copyright © 2023 Sharlatan Hellseher <[email protected]>
-;;; Copyright © 2024 Spencer King <[email protected]>
+;;; Copyright © 2024, 2025 Spencer King <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1466,6 +1466,28 @@ perform optimization and therefore ideal for computer vision applications such
as SLAM (simultaneous localization and mapping).")
(license license:expat))))
+(define-public julia-cpuid
+ (package
+ (name "julia-cpuid")
+ (version "0.3.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/m-j-w/CpuId.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0x2csy8cvd1rm49qpqpkb3zs7swj4r91zdsyjafqr7hvjp9h3hjz"))))
+ (build-system julia-build-system)
+ (propagated-inputs (list julia-precompiletools))
+ (home-page "https://github.com/m-j-w/CpuId.jl")
+ (synopsis "Ask the CPU for its features and specifications")
+ (description
+ "This package allows you to query the availability of specific
+CPU features with low run-time cost.")
+ (license license:expat)))
+
(define-public julia-crayons
(package
(name "julia-crayons")