summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-11-17 22:51:41 +0000
committerSharlatan Hellseher <[email protected]>2024-12-13 20:23:25 +0000
commite0e883e50afa2c20fab4c00758456dde8c28c297 (patch)
treee17d3d784f085a003684a208a03fcff3ec5e2c83 /gnu/packages/python-xyz.scm
parent69302619f24a4d4aad9860baae0b54d0aac4ede2 (diff)
gnu: python-itsdangerous: Update to 2.2.0.
* gnu/packages/python-xyz.scm (python-itsdangerous): Update to 2.2.0. [native-inputs]: Add python-flit-core, python-freezegun, and python-pytest. Change-Id: Icdb420c0b2fad6e0875042b80e577c97e3bbbbe8
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 29123d7952..ce1ac16d1c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6406,15 +6406,18 @@ visualisation and class tracker statistics.")
(define-public python-itsdangerous
(package
(name "python-itsdangerous")
- (version "2.0.1")
+ (version "2.2.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "itsdangerous" version))
(sha256
- (base32
- "1w6gfb2zhbcmrfj6digwzw1z68w6zg1q87rm6la2m412zil4swly"))))
- (build-system python-build-system)
+ (base32 "0wv1bwzbfvpsh4ng5gn4d4mjwvjwpg7w0jgiz8zsbvm1gl5hq1g0"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-flit-core
+ python-freezegun
+ python-pytest))
(home-page "https://palletsprojects.com/p/itsdangerous/")
(synopsis "Python library for passing data to/from untrusted environments")
(description