summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-11-17 20:10:51 +0000
committerSharlatan Hellseher <[email protected]>2024-12-13 20:23:25 +0000
commit69302619f24a4d4aad9860baae0b54d0aac4ede2 (patch)
tree2556acd7d72697cad86233a866ae0dbda4fe4927 /gnu/packages/python-xyz.scm
parent00dfba9d7518d9a9900adeb553b6a2231454cbe8 (diff)
gnu: python-blinker: Update to 1.9.0.
* gnu/packages/python-xyz.scm (python-blinker): Update to 1.9.0. [build-system]: Swapt to pyproject-build-system. [native-inputs]: Add python-flit-core, python-pytest, and python-pytest-asyncio. Change-Id: I0fe81403b9cd08ad9eabe11926f2817304a36ec5
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5263ea3fb4..29123d7952 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8634,15 +8634,19 @@ enable formatting of partial files.")
(define-public python-blinker
(package
(name "python-blinker")
- (version "1.4")
+ (version "1.9.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "blinker" version))
(sha256
(base32
- "1dpq0vb01p36jjwbhhd08ylvrnyvcc82yxx3mwjx6awrycjyw6j7"))))
- (build-system python-build-system)
+ "1gs5aigi8v8k4cymm06gdgaylv5yps6yk5n8gigf9v5blxjj5kml"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-flit-core
+ python-pytest
+ python-pytest-asyncio))
(home-page "https://pythonhosted.org/blinker/")
(synopsis "Fast, simple object-to-object and broadcast signaling")
(description