summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMekeor Melire <[email protected]>2025-02-05 21:12:48 +0000
committerSharlatan Hellseher <[email protected]>2025-02-05 21:54:08 +0000
commit26b022deb98761016e6aaf539109d62ba47d8f5b (patch)
tree395d7df0a096390c14a251e6fd237f2caa5280a3 /gnu/packages/python-web.scm
parent55a2baf1271d8bcd39b876642539ae5e3d9a5892 (diff)
gnu: Add python-domain-connect.
It was preoposed in #48514 on <2021-05-19>. * gnu/packages/python-web.scm (python-domain-connect): New variable. Change-Id: I479ae5a66aaf8cf1a5fcf5bb45583446000a2c64 Reviewed-by: Xinglu Chen <[email protected]> Co-authored-by: Sharlatan Hellseher <[email protected]> Signed-off-by: Sharlatan Hellseher <[email protected]>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 6f6b1dadfe..bb31988d59 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -321,6 +321,42 @@ server process.")
caching server.")
(license license:expat)))
+(define-public python-domain-connect
+ (package
+ (name "python-domain-connect")
+ (version "0.0.11")
+ (source
+ (origin
+ (method git-fetch) ;no tests in PyPI archive
+ (uri (git-reference
+ (url "https://github.com/Domain-Connect/domainconnect_python")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1dhqbx15h074g51mj73j9hlyvb11isjnj4s9ih5kbw1g4vf1q1jk"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ ;; Check and sanity-check phases require /etc/resolv.conf, which is not
+ ;; present in container.
+ #:tests? #f
+ #:phases #~(modify-phases %standard-phases (delete 'sanity-check))))
+ (native-inputs
+ (list python-setuptools
+ python-wheel))
+ (propagated-inputs
+ (list python-cryptography
+ python-dnspython
+ python-future
+ python-publicsuffix
+ python-publicsuffixlist))
+ (home-page "https://github.com/Domain-Connect/domainconnect_python")
+ (synopsis "Client library for Domain Connect protocol")
+ (description
+ "This package provides a Service Provider functionality in both Sync and
+Async mode for @url{https://domainconnect.org/, Domain Connect protocol}.")
+ (license license:expat)))
+
(define-public python-eventlet
(package
(name "python-eventlet")