From 26b022deb98761016e6aaf539109d62ba47d8f5b Mon Sep 17 00:00:00 2001
From: Mekeor Melire <mekeor.melire@gmail.com>
Date: Wed, 5 Feb 2025 21:12:48 +0000
Subject: gnu: Add python-domain-connect.

It was preoposed in #48514 on <2021-05-19>.

* gnu/packages/python-web.scm (python-domain-connect): New variable.

Change-Id: I479ae5a66aaf8cf1a5fcf5bb45583446000a2c64
Reviewed-by: Xinglu Chen <public@yoctocell.xyz>
Co-authored-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
---
 gnu/packages/python-web.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)

(limited to 'gnu/packages/python-web.scm')

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 6f6b1dadfe..bb31988d59 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -321,6 +321,42 @@ (define-public python-devpi-server
 caching server.")
     (license license:expat)))
 
+(define-public python-domain-connect
+  (package
+    (name "python-domain-connect")
+    (version "0.0.11")
+    (source
+     (origin
+       (method git-fetch)               ;no tests in PyPI archive
+       (uri (git-reference
+             (url "https://github.com/Domain-Connect/domainconnect_python")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1dhqbx15h074g51mj73j9hlyvb11isjnj4s9ih5kbw1g4vf1q1jk"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      ;; Check and sanity-check phases require /etc/resolv.conf, which is not
+      ;; present in container.
+      #:tests? #f
+      #:phases #~(modify-phases %standard-phases (delete 'sanity-check))))
+    (native-inputs
+     (list python-setuptools
+           python-wheel))
+    (propagated-inputs
+     (list python-cryptography
+           python-dnspython
+           python-future
+           python-publicsuffix
+           python-publicsuffixlist))
+    (home-page "https://github.com/Domain-Connect/domainconnect_python")
+    (synopsis "Client library for Domain Connect protocol")
+    (description
+     "This package provides a Service Provider functionality in both Sync and
+Async mode for @url{https://domainconnect.org/, Domain Connect protocol}.")
+    (license license:expat)))
+
 (define-public python-eventlet
   (package
     (name "python-eventlet")
-- 
cgit v1.2.3