summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-07 15:26:19 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:47:43 +0000
commit7aa9c96d709c3b9929687a858f824088efb2ab89 (patch)
tree2962f127f9464c351c759bc02ce96bc433e2c4c9 /gnu/packages/golang.scm
parentf14b65cd868ab3788d8aa88daffb95a13a035bdb (diff)
gnu: go-github-com-btcsuite-btclog: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-btcsuite-btclog): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: Idabd6bbe1ecdac641a4a7eab0f391691f4834a00
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm24
1 files changed, 0 insertions, 24 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4a81d4640e..ed5d599fd4 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2701,30 +2701,6 @@ and lookup requests. Browse requests are not supported yet.")
(description "Go wrapper for taglib")
(license license:unlicense))))
-(define-public go-github-com-btcsuite-btclog
- (package
- (name "go-github-com-btcsuite-btclog")
- (version "1.0.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/btcsuite/btclog")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1aqpgb3bw1g5am2az4f1g1a54xii0axvxp0zymhyl8jdk6hhyyd8"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/btcsuite/btclog"))
- (home-page "https://github.com/btcsuite/btclog")
- (synopsis "Subsystem aware logger for Go")
- (description "Package @command{btclog} defines a logger interface and
-provides a default implementation of a subsystem-aware leveled logger
-implementing the same interface.")
- (license license:isc)))
-
(define-public go-github-com-mr-tron-base58
(let ((commit "d724c80ecac7b49e4e562d58b2b4f4ee4ed8c312")
(revision "0"))