summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-07 15:25:09 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:47:42 +0000
commitf14b65cd868ab3788d8aa88daffb95a13a035bdb (patch)
tree30262793caf0583fb91c8a8e9fe289df292ac0dc /gnu/packages/golang.scm
parentdc78cf0633d6eaa681b1217f8d7647a6d815d5cc (diff)
gnu: go-github-com-btcsuite-btclog: Update to 1.0.0.
* gnu/packages/golang.scm (go-github-com-btcsuite-btclog): Update to 1.0.0. Change-Id: I2a45e3e818053b4d5b0785a5a0555726c7856d27
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 7fbf31d5c2..4a81d4640e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2702,21 +2702,19 @@ and lookup requests. Browse requests are not supported yet.")
(license license:unlicense))))
(define-public go-github-com-btcsuite-btclog
- (let ((commit "84c8d2346e9fc8c7b947e243b9c24e6df9fd206a")
- (revision "0"))
(package
(name "go-github-com-btcsuite-btclog")
- (version (git-version "0.0.3" revision commit))
+ (version "1.0.0")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/btcsuite/btclog")
- (commit commit)))
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "02dl46wcnfpg9sqvg0ipipkpnd7lrf4fnvb9zy56jqa7mfcwc7wk"))))
+ "1aqpgb3bw1g5am2az4f1g1a54xii0axvxp0zymhyl8jdk6hhyyd8"))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/btcsuite/btclog"))
@@ -2725,7 +2723,7 @@ and lookup requests. Browse requests are not supported yet.")
(description "Package @command{btclog} defines a logger interface and
provides a default implementation of a subsystem-aware leveled logger
implementing the same interface.")
- (license license:isc))))
+ (license license:isc)))
(define-public go-github-com-mr-tron-base58
(let ((commit "d724c80ecac7b49e4e562d58b2b4f4ee4ed8c312")