summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-09 00:06:10 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:47:48 +0000
commit97cca4c43b8361d705f350d3778d3477bc0f3e61 (patch)
tree0a1e0fa90def85fbfeb25ebc4e26f7cfd5db3e8f /gnu/packages/golang-web.scm
parent060f5adfefe088348e2685087d87a6e2b9b6d28b (diff)
gnu: go-github-com-ssgelm-cookiejarparser: Move to golang-web.
* gnu/packages/golang.scm (go-github-com-ssgelm-cookiejarparser): Move from here ... * gnu/packages/golang-web.scm: ... to here. Change-Id: I258d3f7126c4937421181456c71dc02615707fb2
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 9aba8e441c..2977a902b9 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -7167,6 +7167,32 @@ provided @code{http.FileSystem}.")
"Package jsonrpc2 provides a Go implementation of JSON-RPC 2.0.")
(license license:expat)))
+(define-public go-github-com-ssgelm-cookiejarparser
+ (package
+ (name "go-github-com-ssgelm-cookiejarparser")
+ (version "1.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ssgelm/cookiejarparser")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0fnm53br0cg3iwzniil0lh9w4xd6xpzfypwfpdiammfqavlqgcw4"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:embed-files #~(list "children" "nodes" "text")
+ #:import-path "github.com/ssgelm/cookiejarparser"))
+ (propagated-inputs (list go-golang-org-x-net))
+ (home-page "https://github.com/ssgelm/cookiejarparser")
+ (synopsis "Parse a curl cookiejar with Go")
+ (description
+ "This package is a Go library that parses a curl (netscape) cookiejar
+file into a Go http.CookieJar.")
+ (license license:expat)))
+
(define-public go-github-com-tdewolff-minify-v2
(package
(name "go-github-com-tdewolff-minify-v2")