summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-09 00:01:41 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:47:47 +0000
commit060f5adfefe088348e2685087d87a6e2b9b6d28b (patch)
treefe0ea8676339ecd38287e2869440a30460ea0ca9 /gnu/packages/golang-web.scm
parent5572b70e30bdf63276988e4ade49e55053127490 (diff)
gnu: go-github-com-valyala-tcplisten: Move to golang-web.
* gnu/packages/golang.scm (go-github-com-valyala-tcplisten): Move from here ... * gnu/packages/golang-web.scm: ... to here. Change-Id: I6214029df7e62c1f3fe74253617d6d417dc23b09
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index b50c74df2d..9aba8e441c 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -7468,6 +7468,37 @@ encoding library for the MessagePack, CBOR, JSON and the Binc formats.")
replacement for native @code{net/http} module.")
(license license:expat)))
+(define-public go-github-com-valyala-tcplisten
+ (package
+ (name "go-github-com-valyala-tcplisten")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/valyala/tcplisten")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1fv5hxmq1jwrjn1rdjvbmjrrkb601zcdh01qhx6d8l7ss6n05zb8"))))
+ (build-system go-build-system)
+ (arguments
+ ;; NOTE: (Sharlatan-20211218T165504+0000): Tests failing:
+ ;;
+ ;; tcplisten_test.go:56: cannot create listener 0 using Config
+ ;; &tcplisten.Config{ReusePort:false, DeferAccept:false, FastOpen:false,
+ ;; Backlog:32}: lookup ip6-localhost on [::1]:53: read udp
+ ;; [::1]:33932->[::1]:53: read: connection refused
+ ;;
+ '(#:tests? #f
+ #:import-path "github.com/valyala/tcplisten"))
+ (home-page "https://github.com/valyala/tcplisten")
+ (synopsis "Customizable TCP net.Listener for Go")
+ (description
+ "@code{tcplisten} provides customizable TCP net.Listener with various
+performance-related options.")
+ (license license:expat)))
+
(define-public go-github-com-vektah-gqlparser-v2
(package
(name "go-github-com-vektah-gqlparser-v2")