summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorHerman Rimm <[email protected]>2024-12-03 14:14:52 +0100
committerSharlatan Hellseher <[email protected]>2025-01-21 23:41:49 +0000
commit0477993f4cf9e9483ed0d1825aadcaf4a56e00f6 (patch)
treeb047c29778fad5685f95d3df37957dee8c7e40d3 /gnu/packages/golang-web.scm
parentde7a166943ee70849d909c2dbb25f308407669a1 (diff)
gnu: Add go-github-com-shurcool-githubv4.
* gnu/packages/golang-web.scm (go-github-com-shurcool-githubv4): New variable. Signed-off-by: Sharlatan Hellseher <[email protected]> Change-Id: I2870863792172db990e0f9a58a8e7dc13224bf16
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 6a6dc66f32..a00282d24e 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -5560,6 +5560,33 @@ per host/process
support.")
(license license:expat)))
+(define-public go-github-com-shurcool-githubv4
+ (package
+ (name "go-github-com-shurcool-githubv4")
+ (version "0.0.0-20240429030203-be2daab69064")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/shurcooL/githubv4")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0kkvqwv0waa8hj1jr9b4nvz8rmslqpchidl7gs9bplrkl3fvsxn6"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/shurcooL/githubv4"))
+ (propagated-inputs
+ (list go-github-com-shurcool-graphql
+ go-golang-org-x-oauth2))
+ (home-page "https://github.com/shurcooL/githubv4")
+ (synopsis "Client library for GitHub GraphQL API v4")
+ (description
+ "Package githubv4 is a client library for accessing GitHub @code{GraphQL}
+API v4.")
+ (license license:expat)))
+
(define-public go-github-com-shurcool-graphql
(package
(name "go-github-com-shurcool-graphql")