summaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorHerman Rimm <[email protected]>2024-12-03 14:14:51 +0100
committerSharlatan Hellseher <[email protected]>2025-01-21 23:41:49 +0000
commitde7a166943ee70849d909c2dbb25f308407669a1 (patch)
tree0842b6affe76a8ec279d0162485a81c9f0201df3 /gnu/packages/golang-web.scm
parent4b208b92d8df85004e8c61434a423d8d8e9923b4 (diff)
gnu: Add go-github-com-shurcool-graphql.
* gnu/packages/golang-web.scm (go-github-com-shurcool-graphql): New variable. Signed-off-by: Sharlatan Hellseher <[email protected]> Change-Id: I2a9dc19fe18ee7a6572d3be1bfbbbb5d999c1865
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 75065740ab..6a6dc66f32 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -35,6 +35,7 @@
;;; Copyright © 2024 Dominic Martinez <[email protected]>
;;; Copyright © 2024 Jesse Eisses <[email protected]>
;;; Copyright © 2024 Troy Figiel <[email protected]>
+;;; Copyright © 2024 Herman Rimm <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5559,6 +5560,29 @@ per host/process
support.")
(license license:expat)))
+(define-public go-github-com-shurcool-graphql
+ (package
+ (name "go-github-com-shurcool-graphql")
+ (version "0.0.0-20230722043721-ed46e5a46466")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/shurcooL/graphql")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "12cq16qak217bkpklqsmqhl42gz8cpadpzqw6fsivc3ambjpqdry"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/shurcooL/graphql"))
+ (home-page "https://github.com/shurcooL/graphql")
+ (synopsis "GraphQL client")
+ (description
+ "Package graphql provides a @code{GraphQL} client implementation.")
+ (license license:expat)))
+
(define-public go-github-com-shurcool-httpfs
(package
(name "go-github-com-shurcool-httpfs")