summaryrefslogtreecommitdiff
path: root/gnu/packages/django.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2025-01-12 16:05:03 +0100
committerRicardo Wurmus <[email protected]>2025-01-20 21:37:45 +0100
commite103044a731e3c98df61feda6c552702a00c9aa4 (patch)
tree2025dbfb0bad78b2073003f6d52c0b6a44defca1 /gnu/packages/django.scm
parent91ea847a160365a23c1a7a16201aa4baeb8cbb29 (diff)
gnu: python-django-pipeline: Update to 4.0.0.
* gnu/packages/django.scm (python-django-pipeline): Update to 4.0.0. [build-system]: Use pyproject-build-system. [propagated-inputs]: Add python-jsmin and python-css-html-js-minify. [native-inputs]: Add python-coveralls, python-setuptools, python-tox, and python-wheel; remove python-jsmin and python-css-html-js-minify. Change-Id: I97d84351c4dac2976f1fab33608dfd9ea8bfcc91
Diffstat (limited to 'gnu/packages/django.scm')
-rw-r--r--gnu/packages/django.scm26
1 files changed, 16 insertions, 10 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index dcd93a64c7..ee021763f4 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -952,34 +952,40 @@ to asyncio and Pydantic.")
(define-public python-django-pipeline
(package
(name "python-django-pipeline")
- (version "2.1.0")
+ (version "4.0.0")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "django-pipeline" version))
+ (uri (pypi-uri "django_pipeline" version))
(sha256
(base32
- "194j8xihx5yr1yfrssdy6nxmx8yc999pz2ai9lg83l7izmbcx9in"))))
- (build-system python-build-system)
+ "125wkgi3hf1ly34ps7n63k6agb067h17ngxyf9xjykn6kl6ikc8a"))))
+ (build-system pyproject-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
+ (list
+ #:phases
+ '(modify-phases %standard-phases
(add-after 'unpack 'patch-source
(lambda _
(substitute* "tests/tests/test_compiler.py"
(("\\/usr\\/bin\\/env")
(which "env")))))
(replace 'check
- (lambda*(#:key tests? #:allow-other-keys)
+ (lambda* (#:key tests? #:allow-other-keys)
(when tests?
(setenv "DJANGO_SETTINGS_MODULE" "tests.settings")
(invoke "django-admin" "test" "tests"
"--pythonpath=.")))))))
+ (propagated-inputs
+ (list python-jsmin
+ python-css-html-js-minify))
(native-inputs
- (list python-django
+ (list python-coveralls
+ python-django
+ python-setuptools
python-setuptools-scm
- python-css-html-js-minify
- python-jsmin))
+ python-tox
+ python-wheel))
(home-page
"https://github.com/jazzband/django-pipeline")
(synopsis "Asset packaging library for Django")