summaryrefslogtreecommitdiff
path: root/gnu/packages/django.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2025-01-12 16:03:44 +0100
committerRicardo Wurmus <[email protected]>2025-01-20 21:37:45 +0100
commit91ea847a160365a23c1a7a16201aa4baeb8cbb29 (patch)
treebc7e2460c8271a4d0cb5044704c3f77dd63d2ad2 /gnu/packages/django.scm
parent220ef69e26c8971075c4a700c0ca9017496bacf0 (diff)
gnu: python-django-jinja: Update to 2.11.0.
* gnu/packages/django.scm (python-django-jinja): Update to 2.11.0. [build-system]: Use pyproject-build-system. [arguments]: Simplify 'check phase. [native-inputs]: Add python-setuptools, python-wheel, and tzdata-for-tests. Change-Id: I19567d6de55b2c683f7748baac028df3d2ad1b33
Diffstat (limited to 'gnu/packages/django.scm')
-rw-r--r--gnu/packages/django.scm30
1 files changed, 14 insertions, 16 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index c88885376e..dcd93a64c7 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -720,7 +720,7 @@ merging, minifying and compiling CSS and Javascript files.")
(define-public python-django-jinja
(package
(name "python-django-jinja")
- (version "2.9.1")
+ (version "2.11.0")
(source
(origin
(method git-fetch)
@@ -730,24 +730,22 @@ merging, minifying and compiling CSS and Javascript files.")
(file-name (git-file-name name version))
(sha256
(base32
- "0p9pkn6jjzagpnvcrl9c2vjqamkms7ymvyhhmaqqqhrlv89qnzp7"))))
- (build-system python-build-system)
- (propagated-inputs
- (list python-django python-jinja2 python-pytz python-django-pipeline))
+ "17irzcwxm49iqyn3q2rpfncj41r6gywh938q9myfq7m733vjy2fj"))))
+ (build-system pyproject-build-system)
(arguments
- '(;; TODO Tests currently fail due to issues with the configuration for
- ;; django-pipeline
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
+ (list
+ #:phases
+ '(modify-phases %standard-phases
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
- (or
- (not tests?)
- (with-directory-excursion "testing"
- (invoke "python" "runtests.py"))))))))
- (home-page
- "https://niwinz.github.io/django-jinja/latest/")
+ (when tests?
+ (with-directory-excursion "testing"
+ (invoke "python" "runtests.py"))))))))
+ (propagated-inputs
+ (list python-django python-jinja2 python-pytz python-django-pipeline))
+ (native-inputs
+ (list python-setuptools python-wheel tzdata-for-tests))
+ (home-page "https://niwinz.github.io/django-jinja/latest/")
(synopsis "Simple jinja2 templating backend for Django")
(description
"This package provides a templating backend for Django, using Jinja2. It