summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2025-01-14 11:36:41 +0100
committerRicardo Wurmus <rekado@elephly.net>2025-01-20 21:37:54 +0100
commiteee88d70aadc187bd97239d6bf264d27d8f2c7ad (patch)
tree7ef7d8e575f25cc45e87bf4313ebbfbeb066d68b /gnu/packages/databases.scm
parent21d41c3130240700e680e17bf2a61f155b49fbb8 (diff)
gnu: python-hiredis: Update to 3.1.0.
* gnu/packages/patches/python-hiredis-fix-header.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove patch. * gnu/packages/databases.scm (python-hiredis): Update to 3.1.0. [source]: Remove patch. [arguments]: Remove. Change-Id: I095c89329e4c42316398c7fccc86e1dee0affaea
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm14
1 files changed, 3 insertions, 11 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 3b3961c5d1..1ce55e7d0c 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -4539,7 +4539,7 @@ for Python. The design goals are:
(define-public python-hiredis
(package
(name "python-hiredis")
- (version "2.2.2")
+ (version "3.1.0")
(source (origin
(method git-fetch) ;for tests
(uri (git-reference
@@ -4548,18 +4548,10 @@ for Python. The design goals are:
(file-name (git-file-name name version))
(sha256
(base32
- "066rm5m7aa8skm0a57cf45153bwmbl9yyi4s60an14hb25n947gi"))
+ "1g9qj37phq9989av0bwkqy40f5wx9q08y19dsmzwd1ssqsxwhfav"))
(patches
- (search-patches "python-hiredis-fix-header.patch"
- "python-hiredis-use-system-hiredis.patch"))))
+ (search-patches "python-hiredis-use-system-hiredis.patch"))))
(build-system pyproject-build-system)
- (arguments
- (list #:phases #~(modify-phases %standard-phases
- (add-before 'check 'delete-extraneous-__init__.py
- (lambda _
- ;; The fix was forwarded upstream, see:
- ;; https://github.com/redis/hiredis-py/pull/160.
- (delete-file "tests/__init__.py"))))))
(native-inputs (list python-pytest python-setuptools python-wheel))
(inputs (list hiredis))
(home-page "https://github.com/redis/hiredis-py")