summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/databases.scm14
-rw-r--r--gnu/packages/patches/python-hiredis-fix-header.patch49
3 files changed, 3 insertions, 61 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index f91bf47d66..763c790541 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -2093,7 +2093,6 @@ dist_patch_DATA = \
%D%/packages/patches/python-debugpy-unbundle-pydevd.patch \
%D%/packages/patches/python-docopt-pytest6-compat.patch \
%D%/packages/patches/python-fixtures-remove-monkeypatch-test.patch \
- %D%/packages/patches/python-hiredis-fix-header.patch \
%D%/packages/patches/python-hiredis-use-system-hiredis.patch \
%D%/packages/patches/python-online-judge-api-client-tests.patch \
%D%/packages/patches/python-optree-fix-32-bit.patch \
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 3b3961c5d1..1ce55e7d0c 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -4539,7 +4539,7 @@ for Python. The design goals are:
(define-public python-hiredis
(package
(name "python-hiredis")
- (version "2.2.2")
+ (version "3.1.0")
(source (origin
(method git-fetch) ;for tests
(uri (git-reference
@@ -4548,18 +4548,10 @@ for Python. The design goals are:
(file-name (git-file-name name version))
(sha256
(base32
- "066rm5m7aa8skm0a57cf45153bwmbl9yyi4s60an14hb25n947gi"))
+ "1g9qj37phq9989av0bwkqy40f5wx9q08y19dsmzwd1ssqsxwhfav"))
(patches
- (search-patches "python-hiredis-fix-header.patch"
- "python-hiredis-use-system-hiredis.patch"))))
+ (search-patches "python-hiredis-use-system-hiredis.patch"))))
(build-system pyproject-build-system)
- (arguments
- (list #:phases #~(modify-phases %standard-phases
- (add-before 'check 'delete-extraneous-__init__.py
- (lambda _
- ;; The fix was forwarded upstream, see:
- ;; https://github.com/redis/hiredis-py/pull/160.
- (delete-file "tests/__init__.py"))))))
(native-inputs (list python-pytest python-setuptools python-wheel))
(inputs (list hiredis))
(home-page "https://github.com/redis/hiredis-py")
diff --git a/gnu/packages/patches/python-hiredis-fix-header.patch b/gnu/packages/patches/python-hiredis-fix-header.patch
deleted file mode 100644
index 168b76920d..0000000000
--- a/gnu/packages/patches/python-hiredis-fix-header.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-Upstream status: https://github.com/redis/hiredis-py/pull/159
-
-From c2a20695aae53de7b5160e29675344df0b805fa6 Mon Sep 17 00:00:00 2001
-From: Maxim Cournoyer <[email protected]>
-Date: Sat, 18 Mar 2023 15:18:08 -0400
-Subject: [PATCH] pack: Replace sdsalloc.h with alloc.h
-
-Fixes #158.
-
-* src/pack.c: Replace sdsalloc.h with alloc.h.
-(pack_command): Replace s_malloc with hi_malloc.
----
- src/pack.c | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/src/pack.c b/src/pack.c
-index 443e9d3..23e4004 100644
---- a/src/pack.c
-+++ b/src/pack.c
-@@ -16,7 +16,7 @@ extern sds sdscpylen(sds s, const char *t, size_t len);
- extern sds sdsnewlen(const void *init, size_t initlen);
- #endif
-
--#include <hiredis/sdsalloc.h>
-+#include <hiredis/alloc.h>
-
- PyObject *
- pack_command(PyObject *cmd)
-@@ -32,7 +32,7 @@ pack_command(PyObject *cmd)
- }
-
- Py_ssize_t tokens_number = PyTuple_Size(cmd);
-- sds *tokens = s_malloc(sizeof(sds) * tokens_number);
-+ sds *tokens = hi_malloc(sizeof(sds) * tokens_number);
- if (tokens == NULL)
- {
- return PyErr_NoMemory();
-@@ -118,4 +118,4 @@ cleanup:
- sdsfreesplitres(tokens, tokens_number);
- hi_free(lengths);
- return result;
--}
-\ No newline at end of file
-+}
-
-base-commit: 8adb1b3cb38b82cdc73fa2d72879712da1f74e70
---
-2.39.1
-