summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-03 20:35:02 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:27:50 +0000
commitfbfff97ea9464eac3ed831570cf44c498e69144d (patch)
treecc3eafff98d097e74ce0acf42162bc4439b38ac9
parentf165f68188c77b17e3a5dd05748b747d9868998d (diff)
gnu: xsimd: Update to 11.0.0.
* gnu/packages/cpp.scm (xsimd): Update to 11.0.0. [native-inputs]: Add doctest. Change-Id: I8c49ff34288cdf5429034668ddd496c345ddfb34
-rw-r--r--gnu/packages/cpp.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index c8a087073f..cf3ccfbb55 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -42,6 +42,7 @@
;;; Copyright © 2024 dan <[email protected]>
;;; Copyright © 2024 Peepo Froggings <[email protected]>
;;; Copyright © 2024 Jakob Kirsch <[email protected]>
+;;; Copyright © 2025 Sharlatan Hellseher <[email protected]>
;;; This file is part of GNU Guix.
;;;
@@ -606,7 +607,7 @@ enabled in different parts of your code.")
(define-public xsimd
(package
(name "xsimd")
- (version "9.0.1")
+ (version "11.0.0")
(source
(origin
(method git-fetch)
@@ -614,7 +615,7 @@ enabled in different parts of your code.")
(url "https://github.com/xtensor-stack/xsimd")
(commit version)))
(sha256
- (base32 "1fcy0djwpwvls6yqxqa82s4l4gvwkqkr8i8bibbb3dm0lqvhnw52"))
+ (base32 "148wylv88vp31rz7l357ch7k0l50apfk4x31qdqk9y4d2hj6ld3f"))
(file-name (git-file-name name version))))
(build-system cmake-build-system)
(arguments
@@ -622,7 +623,8 @@ enabled in different parts of your code.")
#:configure-flags #~(list "-DBUILD_TESTS=ON")
#:test-target "xtest"))
(native-inputs
- (list googletest))
+ (list doctest
+ googletest))
(home-page "https://github.com/xtensor-stack/xsimd")
(synopsis "C++ wrappers for SIMD intrinsics and math implementations")
(description