summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-03 20:35:01 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:27:39 +0000
commitf165f68188c77b17e3a5dd05748b747d9868998d (patch)
tree1cf55c9e840c1b523ae9650af5454f317fc42069
parent6dd219387940ba02db02cc81b35cd7437c108287 (diff)
gnu: xsimd: Improve package style.
* gnu/packages/cpp.scm (xsimd) [source] <url>: Fix redirection issue, <https://github.com/QuantStack/xsimd> permamently redirects to <https://github.com/xtensor-stack/xsimd>. [arguments]: Use G-expressions. [description]: Adjust fill column indentation. Change-Id: I8096e07c026c9f08a9d647a44f9930900b3ae1bd
-rw-r--r--gnu/packages/cpp.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 17b1c514d5..c8a087073f 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -611,25 +611,26 @@ enabled in different parts of your code.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/QuantStack/xsimd")
+ (url "https://github.com/xtensor-stack/xsimd")
(commit version)))
(sha256
(base32 "1fcy0djwpwvls6yqxqa82s4l4gvwkqkr8i8bibbb3dm0lqvhnw52"))
(file-name (git-file-name name version))))
(build-system cmake-build-system)
(arguments
- `(#:configure-flags (list "-DBUILD_TESTS=ON")
- #:test-target "xtest"))
+ (list
+ #:configure-flags #~(list "-DBUILD_TESTS=ON")
+ #:test-target "xtest"))
(native-inputs
(list googletest))
(home-page "https://github.com/xtensor-stack/xsimd")
(synopsis "C++ wrappers for SIMD intrinsics and math implementations")
(description
- "xsimd provides a unified means for using @acronym{SIMD, single instruction
-multiple data} features for library authors. Namely, it enables manipulation of
-batches of numbers with the same arithmetic operators as for single values.
-It also provides accelerated implementation of common mathematical functions
-operating on batches.")
+ "xsimd provides a unified means for using @acronym{SIMD, single
+instruction multiple data} features for library authors. Namely, it enables
+manipulation of batches of numbers with the same arithmetic operators as for
+single values. It also provides accelerated implementation of common
+mathematical functions operating on batches.")
(license license:bsd-3)))
(define-public google-highway