summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCayetano Santos <[email protected]>2024-12-10 11:41:08 +0100
committerLudovic Courtès <[email protected]>2025-01-07 19:03:35 +0100
commiteeb019eb595bbb29f83389deb2fc823ed6402dd5 (patch)
tree91699de7b420cead9920127956bded31ebc67871
parent3f1da2f4a25f09bb5081be3e36aca1fc42d45a3b (diff)
gnu: Add python-hdlmake.
* gnu/packages/fpga.scm (python-hdlmake): New variable. Change-Id: I4f19d2cceb7fe46bbc359f9bc5197ae3113bb3d7 Co-authored-by: Ludovic Courtès <[email protected]>
-rw-r--r--gnu/packages/fpga.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index 9116a4f151..c757353ac6 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -36,6 +36,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system cmake)
#:use-module (guix build-system python)
+ #:use-module (guix build-system pyproject)
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
#:use-module (gnu packages algebra)
@@ -66,6 +67,7 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
#:use-module (gnu packages readline)
@@ -745,3 +747,31 @@ hardware designs in Verilog.")
to an FPGA.")
(home-page "https://trabucayre.github.io/openFPGALoader")
(license license:asl2.0)))
+
+(define-public python-hdlmake
+ (let ((commit "3cb248fdad601c579b59fd7c194402871209bc54")
+ (revision "0"))
+ (package
+ (name "python-hdlmake")
+ (version (git-version "3.3" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://ohwr.org/project/hdl-make")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "08ivnhxyp44agmifqb4pjbxj23p43qqcg73s2y2z1hqk2six3fdx"))))
+ (build-system pyproject-build-system)
+ (arguments
+ `(#:tests? #f))
+ (native-inputs (list python-setuptools python-wheel))
+ (propagated-inputs (list python-six))
+ (home-page "https://ohwr.org/projects/hdl-make")
+ (synopsis "Generate multi-purpose makefiles for HDL projects")
+ (description
+ "Hdlmake helps manage and share @acronym{HDL, hardware description
+language} code by automatically finding file dependencies, writing synthesis
+and simulation Makefiles.")
+ (license license:gpl3+))))