summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCayetano Santos <[email protected]>2024-11-08 23:54:47 +0100
committerLudovic Courtès <[email protected]>2025-01-07 18:58:31 +0100
commit3f1da2f4a25f09bb5081be3e36aca1fc42d45a3b (patch)
tree348f9d6e510ade811386253a887b3e62574296a1
parent952a179f4415823efbae3fa7d8d49f5fb878c89e (diff)
gnu: Add python-vunit.
* gnu/packages/fpga.scm (python-vunit): New variable. Change-Id: Ieb16ec16928e6b0b2af6992fd9566cb946990dad Signed-off-by: Ludovic Courtès <[email protected]>
-rw-r--r--gnu/packages/fpga.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index 8e3ee00122..9116a4f151 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -521,6 +521,34 @@ constructed by a Python program.")
a hardware description and verification language.")
(license license:lgpl2.1+)))
+(define-public python-vunit
+ (package
+ (name "python-vunit")
+ (version "4.7.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/VUnit/vunit")
+ (commit (string-append "v" version))
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0s7j5bykbv34wgnxy5cl4zp6g0caidvzs8pd9yxjq341543xkjwm"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f)) ;XXX: requires setuptools_scm >= 2.0.0, <3
+ (propagated-inputs (list python python-colorama))
+ (home-page "https://vunit.github.io")
+ (synopsis "Unit testing framework for VHDL/SystemVerilog")
+ (description
+ "VUnit features the functionality needed to realize continuous and
+automated testing of HDL code.")
+
+ ;; According to 'LICENSE.rst', VUnit itself is under MPL but two
+ ;; subdirectories are under ASL.
+ (license (list license:mpl2.0 license:asl2.0))))
+
(define-public nvc
(package
(name "nvc")