summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <[email protected]>2024-11-06 00:14:59 +0100
committerEfraim Flashner <[email protected]>2025-01-07 09:03:32 +0200
commite426f525700ccd04ef55bffa010943909470b7d0 (patch)
tree95f814c3b675173fdcf13734a67b76b45f5a246f
parent825c895ec32e7ef49230c744d74c5569d27fe3f5 (diff)
gnu: Add rust-primal-sieve-0.3.
* gnu/packages/crates-io.scm (rust-primal-sieve-0.3): New variable. Signed-off-by: Efraim Flashner <[email protected]> Change-Id: I277c07088ed786420e596bd6a9a65d34a16db6f3
-rw-r--r--gnu/packages/crates-io.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 1f2834363e..4170bea177 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -56112,6 +56112,31 @@ prime-number-related needs of @code{rust-primal}.")
bounds for the number of primes below n and the k-th prime.")
(license (list license:expat license:asl2.0))))
+(define-public rust-primal-sieve-0.3
+ (package
+ (name "rust-primal-sieve")
+ (version "0.3.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "primal-sieve" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1lzdllk78jqdp93h15l69s4xglbjcf6jlq6khccka0r2v2b2g64f"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-primal-bit" ,rust-primal-bit-0.3)
+ ("rust-primal-estimate" ,rust-primal-estimate-0.3)
+ ("rust-smallvec" ,rust-smallvec-1))
+ #:cargo-development-inputs
+ (("rust-criterion" ,rust-criterion-0.3)
+ ("rust-primal" ,rust-primal-0.3)
+ ("rust-primal-slowsieve" ,rust-primal-slowsieve-0.3))))
+ (home-page "https://github.com/huonw/primal")
+ (synopsis "Prime sieve")
+ (description "This package provides a high performance prime sieve.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-print-bytes-1
(package
(name "rust-print-bytes")