summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <[email protected]>2024-11-06 00:14:58 +0100
committerEfraim Flashner <[email protected]>2025-01-07 09:03:31 +0200
commit825c895ec32e7ef49230c744d74c5569d27fe3f5 (patch)
tree4b27d6caf698ee3ad951627b6de4d444baba4936
parent634186b812c359e2eaffebfe1efa254f4c41ebdd (diff)
gnu: Add rust-primal-estimate-0.3.
* gnu/packages/crates-io.scm (rust-primal-estimate-0.3): New variable. Signed-off-by: Efraim Flashner <[email protected]> Change-Id: Ia5ffae4e7d8ee932a1275102ea6ea38338798725
-rw-r--r--gnu/packages/crates-io.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 77a747c44e..1f2834363e 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -56091,6 +56091,27 @@ prime-number-related needs of @code{rust-primal}.")
"This package provides a standalone primality testing tool.")
(license (list license:expat license:asl2.0))))
+(define-public rust-primal-estimate-0.3
+ (package
+ (name "rust-primal-estimate")
+ (version "0.3.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "primal-estimate" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "08nq0n0r35rni65h79fynync0wyy8agrxy5mfmg0hq9s1c510cm4"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-development-inputs (("rust-primal" ,rust-primal-0.3))))
+ (home-page "https://github.com/huonw/primal")
+ (synopsis "Estimate upper and lower bounds for the k-th prime")
+ (description
+ "This package provides a state-of-the-art estimation of upper and lower
+bounds for the number of primes below n and the k-th prime.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-print-bytes-1
(package
(name "rust-print-bytes")