summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2025-03-02 20:12:53 +0200
committerEfraim Flashner <[email protected]>2025-03-03 08:38:46 +0200
commitb14b93621dfa17e043ad7a7eaf75d289b7a62044 (patch)
tree7cc0586eac3fcd7fa4aeb0b2e447db8fd0cd93b2
parentfeba33d2c1f47f7292e51a61a506b81cea666aa7 (diff)
gnu: python-pytest-xprocess: Skip some tests on riscv64-linux.
* gnu/packages/check.scm (python-pytest-xprocess)[arguments]: When building for riscv64-linux add some test-flags to skip some tests. Change-Id: Ie9712c660b774f67a48bfbc44ed08682ab3e2083
-rw-r--r--gnu/packages/check.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index c1d71498a0..b54794a766 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2015, 2017 Cyril Roelandt <[email protected]>
;;; Copyright © 2015 Federico Beffa <[email protected]>
;;; Copyright © 2015 Andreas Enge <[email protected]>
-;;; Copyright © 2015, 2016, 2018-2024 Efraim Flashner <[email protected]>
+;;; Copyright © 2015, 2016, 2018-2025 Efraim Flashner <[email protected]>
;;; Copyright © 2016, 2017 Leo Famulari <[email protected]>
;;; Copyright © 2016 Christine Lemmer-Webber <[email protected]>
;;; Copyright © 2016, 2017 Danny Milosavljevic <[email protected]>
@@ -2757,6 +2757,15 @@ enables you to test server connections locally.")
(sha256
(base32 "03y61h42sc343ddhsz7glxmv9ga83k4grrayfmbbrsl6fmip1qhm"))))
(build-system pyproject-build-system)
+ (arguments
+ (if (target-riscv64?)
+ (list
+ #:test-flags
+ #~(list "-k"
+ ;; Unclear why these tests are failing on riscv64-linux.
+ (string-append "not test_startup_without_pattern"
+ " and not test_startup_with_pattern_and_callback")))
+ '()))
(native-inputs
(list python-setuptools
python-setuptools-scm