summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2025-03-03 08:06:59 +0200
committerEfraim Flashner <[email protected]>2025-03-03 08:06:59 +0200
commitfeba33d2c1f47f7292e51a61a506b81cea666aa7 (patch)
treec6fbee52b59f9c411e501279427f88136703b108
parentc991c49f09d6fd2764e1f7bdae54c097c748524f (diff)
gnu: python-websockets: Fix test suite on riscv64-linux.
* gnu/packages/python-web.scm (python-websockets)[arguments]: When building for riscv64-linux use an even longer test timeout. Change-Id: I83390a5e5e8d9e1ab6514841feca8e5066d6c80d
-rw-r--r--gnu/packages/python-web.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 06b3848e0a..18c4931c49 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -7974,7 +7974,11 @@ files.")
#~(modify-phases %standard-phases
(add-before 'check 'extend-test-timeout
(lambda _
- (setenv "WEBSOCKETS_TESTS_TIMEOUT_FACTOR" "10"))))))
+ ;; Some architectures need an even longer timeout. Make it
+ ;; long enough that it should never fail due to timeout.
+ #$@(if (target-riscv64?)
+ #~((setenv "WEBSOCKETS_TESTS_TIMEOUT_FACTOR" "100"))
+ #~((setenv "WEBSOCKETS_TESTS_TIMEOUT_FACTOR" "10"))))))))
(native-inputs
(list python-setuptools
python-wheel))