summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-18 02:57:09 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:05 +0000
commit84f2a1791534cd83bcae79a3e78b7becc8df3964 (patch)
treebc22fd03835f6ca91d9e73a3c1fedbf3b4499b63
parent15cbecf43583c99968294a06743d750afb140aa7 (diff)
gnu: Add go-github-com-remyoudompheng-bigfft.
* gnu/packages/golang-maths.scm (go-github-com-remyoudompheng-bigfft): New variable. Change-Id: I659183495f68b7b29708020ff11c837e121c34ad
-rw-r--r--gnu/packages/golang-maths.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang-maths.scm b/gnu/packages/golang-maths.scm
index 4d5515c82d..8ecdf9948f 100644
--- a/gnu/packages/golang-maths.scm
+++ b/gnu/packages/golang-maths.scm
@@ -144,6 +144,30 @@ and GCC’s decimal extension.")
"This package provides a statistical library for Golang.")
(license license:expat)))
+(define-public go-github-com-remyoudompheng-bigfft
+ (package
+ (name "go-github-com-remyoudompheng-bigfft")
+ (version "0.0.0-20230129092748-24d4a6f8daec")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/remyoudompheng/bigfft")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0qxfda0jq70ank99zlgfz7iig2jpicbbxnpr7xcf1v9p474ak2dx"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/remyoudompheng/bigfft"))
+ (home-page "https://github.com/remyoudompheng/bigfft")
+ (synopsis "Big integer multiplication library for using Fast Fourier transform")
+ (description
+ "Package bigfft implements multiplication of @code{big.Int} using
+FFT (Schonhage-Strassen method for multiplying integers).")
+ (license license:bsd-3)))
+
(define-public go-github-com-shopspring-decimal
(package
(name "go-github-com-shopspring-decimal")