summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-18 02:50:11 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:05 +0000
commit15cbecf43583c99968294a06743d750afb140aa7 (patch)
tree4aa27d2d9564df1797682b61311c5e89a1862b94
parentfa6e7f7f1b5150098c046ac90bba37eeb5cb40ad (diff)
gnu: Add go-modernc-org-token.
* gnu/packages/golang-web.scm (go-modernc-org-token): New variable. Change-Id: I6288f8f80f703e5dc8eefd788079ae229b34001a
-rw-r--r--gnu/packages/golang-web.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index f041a5e47c..9debc0f957 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -6875,6 +6875,30 @@ but implement that subset with little to no assumption about the structure of
the code or routes.")
(license license:asl2.0)))
+(define-public go-modernc-org-token
+ (package
+ (name "go-modernc-org-token")
+ (version "1.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/cznic/token")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1vvnnfppmgq7hxmw18dx90fg6khwnxpwn9kwwf0hwxsckxfb5icv"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "modernc.org/token"))
+ (home-page "https://modernc.org/token")
+ (synopsis "Variant of the Golang stdlib package @code{token}")
+ (description
+ "Package token is variant of the stdlib package token with types
+@code{FileSet} and Token removed.")
+ (license license:bsd-3)))
+
(define-public go-mvdan-cc-xurls-v2
(package
(name "go-mvdan-cc-xurls-v2")