summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-18 02:34:41 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:05 +0000
commitfa6e7f7f1b5150098c046ac90bba37eeb5cb40ad (patch)
tree071d08341f631f8a4d1068bf974afeecec47e3e6
parent539ac5dedcab79c12a8a19accb29c4fc200ae9e9 (diff)
gnu: go-github-com-go-ldap-ldap-v3: Update to 3.4.9.
* gnu/packages/golang-web.scm (go-github-com-go-ldap-ldap-v3): Update to 3.4.9. [arguments]<test-flags>: Move test skip logic here and skipp all failing tests requiring running LDAP service. [propagated-inputs]: Add go-github-com-jcmturner-gokrb5-v8. Change-Id: I8edbb25dc5e1dd8e228f2aaa059e36db24a4f7cb
-rw-r--r--gnu/packages/golang-web.scm33
1 files changed, 21 insertions, 12 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index b23736ed83..f041a5e47c 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1872,7 +1872,7 @@ Encryption, JSON Web Signature, and JSON Web Token standards.")
(define-public go-github-com-go-ldap-ldap-v3
(package
(name "go-github-com-go-ldap-ldap-v3")
- (version "3.4.8")
+ (version "3.4.9")
(source
(origin
(method git-fetch)
@@ -1881,26 +1881,35 @@ Encryption, JSON Web Signature, and JSON Web Token standards.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0fbmhlc8ss5vn6zz0iiifvy4pm0mwaf13qpz70k83mmnv9vrv16x"))))
+ (base32 "0qcm4piyk7l5n3kplcism0y7zp40xcfmjl04hw1s276qqf7vi6hg"))))
(build-system go-build-system)
(arguments
(list
#:import-path "github.com/go-ldap/ldap/v3"
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'remove-failing-tests
- (lambda* (#:key import-path #:allow-other-keys)
- (with-directory-excursion (string-append "src/" import-path)
- (for-each delete-file
- ;; FAIL <...> LDAP Result Code 200 "Network Error":
- ;; dial tcp: lookup ldap.itd.umich.edu on <...>
- (list "ldap_test.go"))))))))
+ #:test-flags
+ #~(list "-skip" (string-join
+ (list "TestCompare"
+ "TestExtendedRequest_WhoAmI"
+ "TestExtendedRequest_FastBind"
+ "TestMatchDNError"
+ "TestMultiGoroutineSearch"
+ "TestSearch"
+ "TestSearchAsync"
+ "TestSearchAsyncAndCancel"
+ "TestSearchStartTLS"
+ "TestSearchWithPaging"
+ "TestSecureDialURL"
+ "TestStartTLS"
+ "TestTLSConnectionState"
+ "TestUnsecureDialURL")
+ "|"))))
(native-inputs
(list go-github-com-stretchr-testify))
(propagated-inputs
(list go-github-com-azure-go-ntlmssp
go-github-com-go-asn1-ber-asn1-ber
- go-github-com-google-uuid))
+ go-github-com-google-uuid
+ go-github-com-jcmturner-gokrb5-v8))
(home-page "https://github.com/go-ldap/ldap")
(synopsis "LDAP v3 functionality for Go")
(description "This package provides basic LDAP v3 functionality in the Go