summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntero Mejr <[email protected]>2023-06-04 17:42:18 +0000
committerDanny Milosavljevic <[email protected]>2024-12-22 13:13:30 +0100
commit7bc9a96c38de5ed14af45fe53bc9acbd25fda190 (patch)
treec2fdeeb7c15bbe66cee352d15a762a07ea84a79e
parentfda636721ae31203390cdc83b4a1bc2d74b4087a (diff)
gnu: Add perl-gd.
* gnu/packages/perl.scm (perl-gd): New variable. Signed-off-by: Danny Milosavljevic <[email protected]>
-rw-r--r--gnu/packages/perl.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 7a2cd2a3d6..3f3425fbcd 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -5654,6 +5654,28 @@ defining functions and methods with parameter lists. At minimum this saves you
from having to unpack @code{@@_} manually, but this module can do much more.")
(license license:perl-license)))
+(define-public perl-gd
+ (package
+ (name "perl-gd")
+ (version "2.77")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/R/RU/RURBAN/GD-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1dbg040nkbv8jjgabzjpmay5ysvg3cgxsqmv5771dq1vxyw8hv5m"))))
+ (build-system perl-build-system)
+ (native-inputs (list perl-extutils-pkgconfig perl-test-fork))
+ (inputs (list gd))
+ (home-page "https://metacpan.org/release/GD")
+ (synopsis "Perl interface to the libgd graphics library")
+ (description
+ "@file{GD.pm} is a Perl interface to the gd graphics library. GD allows
+you to create color drawings using a large number of graphics primitives, and
+emit the drawings as PNG files.")
+ (license license:perl-license)))
+
(define-public perl-getopt-argvfile
(package
(name "perl-getopt-argvfile")