summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntero Mejr <[email protected]>2023-06-04 17:42:17 +0000
committerDanny Milosavljevic <[email protected]>2024-12-22 13:13:29 +0100
commitfda636721ae31203390cdc83b4a1bc2d74b4087a (patch)
treec9a0ab891828638f71f88eff2a2df0bad8bd309c
parent6ca5c2e50e2b3161245123cc87103e94e9af9e63 (diff)
gnu: Add perl-function-parameters.
* gnu/packages/perl.scm (perl-function-parameters): New variable. Signed-off-by: Danny Milosavljevic <[email protected]>
-rw-r--r--gnu/packages/perl.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index f6a6352a72..7a2cd2a3d6 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -5631,6 +5631,29 @@ Linux, fsevents on OS X, @code{kqueue} on FreeBSD, and
back to a full directory scan if none of these are available.")
(license license:perl-license)))
+(define-public perl-function-parameters
+ (package
+ (name "perl-function-parameters")
+ (version "2.002003")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/M/MA/MAUKE/Function-Parameters-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0ba317h659jrvnqf816ygyh656j8n524985na42irhzbx0qkqlak"))))
+ (build-system perl-build-system)
+ (native-inputs (list perl-test-fatal))
+ (home-page "https://metacpan.org/release/Function-Parameters")
+ (synopsis
+ "Define functions and methods with parameter lists")
+ (description
+ "This module provides two new keywords, @code{fun} and @code{method}, for
+defining functions and methods with parameter lists. At minimum this saves you
+from having to unpack @code{@@_} manually, but this module can do much more.")
+ (license license:perl-license)))
+
(define-public perl-getopt-argvfile
(package
(name "perl-getopt-argvfile")