summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <[email protected]>2025-01-25 14:33:24 +0100
committerDanny Milosavljevic <[email protected]>2025-01-25 17:24:11 +0100
commit6b9e1cd26f6d143f138f01d46a46139f1e7909e0 (patch)
tree7462bfa47a17781aba6eb7567ae8fdbcae16e183
parentad4a5e5a50ece12ec00fdda8f8a6e360e21a1e35 (diff)
gnu: Add python-nfcpy.
* gnu/packages/python-xyz.scm (python-nfcpy): New variable. Change-Id: I4b7a3fec8999d23c8d734d3b683c52ba023f8644
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 14c62db47a..912d8db184 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -38925,6 +38925,28 @@ client library.")
Data Exchange Format decoder and encoder.")
(license license:isc)))
+(define-public python-nfcpy
+ (package
+ (name "python-nfcpy")
+ (version "1.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "nfcpy" version))
+ (sha256
+ (base32 "0sxgp298i8y17i9drp8sclxx0i3vn0wgh5ajs2arw7cy2780igg5"))))
+ (build-system pyproject-build-system)
+ (arguments
+ `(#:tests? #f)) ; Tests use nfc.ndef even though that has been removed.
+ (propagated-inputs (list python-libusb1 python-ndeflib python-pydes
+ python-pyserial))
+ (native-inputs (list python-setuptools python-wheel))
+ (home-page "https://github.com/nfcpy/nfcpy")
+ (synopsis "Python module for Near-Field Communication.")
+ (description "This package provides a Python module for Near-Field
+Communication.")
+ (license license:eupl1.1)))
+
(define-public python-clrprint
(package
(name "python-clrprint")