summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <[email protected]>2025-01-25 14:32:08 +0100
committerDanny Milosavljevic <[email protected]>2025-01-25 17:24:11 +0100
commitad4a5e5a50ece12ec00fdda8f8a6e360e21a1e35 (patch)
tree48f3be7534d75704fc2fed4e83375a1f5c729551
parentef7019e54802942de4880ba6400ebda8e49b2c84 (diff)
gnu: Add python-ndeflib.
* gnu/packages/python-xyz.scm (python-ndeflib): New variable. Change-Id: Ifbff48257b0b2124f0dbbb1621a1c35dd2907fba
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 41d1f11399..14c62db47a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -38907,6 +38907,24 @@ Currently, Linux is the only platform supported by this library.")
client library.")
(license license:expat)))
+(define-public python-ndeflib
+ (package
+ (name "python-ndeflib")
+ (version "0.3.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ndeflib" version))
+ (sha256
+ (base32 "122a8prbcj070y3fl82kvxmbciv36hj1h1d448l6zcdrb22q4mhx"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-setuptools python-wheel))
+ (home-page "https://ndeflib.readthedocs.io/")
+ (synopsis "NFC Data Exchange Format decoder and encoder.")
+ (description "This package provides a NFC (Near-Field Communication)
+Data Exchange Format decoder and encoder.")
+ (license license:isc)))
+
(define-public python-clrprint
(package
(name "python-clrprint")