summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-03 20:35:06 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:27:52 +0000
commit5d6e4cedb5666e01a3ba97d27b5eef6a82ff7875 (patch)
tree2b86c76f6a9f97924ff4f44bd20ec0e032f43e0e
parent5115dacc571c43da9589c4a99c9d0064c0bd37e1 (diff)
gnu: xtensor: Update to 0.25.0.
* gnu/packages/algebra.scm (xtensor): Update to 0.25.0. [native-inputs]: Add nlohmann-json. Change-Id: Iccaf397423d2a2b7b008082a9761c89ca2adc9a2
-rw-r--r--gnu/packages/algebra.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 310ca6589b..7c22e811d5 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2021 Lars-Dominik Braun <[email protected]>
;;; Copyright © 2022 Maxim Cournoyer <[email protected]>
;;; Copyright © 2023 Mehmet Tekman <[email protected]>
+;;; Copyright © 2025 Sharlatan Hellseher <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1163,7 +1164,7 @@ features, and more.")
(define-public xtensor
(package
(name "xtensor")
- (version "0.24.6")
+ (version "0.25.0")
(source
(origin
(method git-fetch)
@@ -1171,7 +1172,7 @@ features, and more.")
(url "https://github.com/xtensor-stack/xtensor")
(commit version)))
(sha256
- (base32 "0gf5m5p61981pv7yh5425lcv8dci948ri37hn1zlli7xg54x0g3i"))
+ (base32 "0ziqybfm0fh6kr8qwxqacr04m9gm0njbn520izm6rsh9hysxsmw5"))
(file-name (git-file-name name version))))
(build-system cmake-build-system)
(arguments
@@ -1181,6 +1182,7 @@ features, and more.")
(native-inputs
(list doctest
googletest
+ nlohmann-json
xtl))
(home-page "https://xtensor.readthedocs.io/en/latest/")
(synopsis "C++ tensors with broadcasting and lazy computing")