summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-03 20:35:05 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:27:51 +0000
commit5115dacc571c43da9589c4a99c9d0064c0bd37e1 (patch)
treefd0280ae90289717686f090baf489f367612d4cd
parente25dcf3bad54cfdd69c64ac768c861a939c1e322 (diff)
gnu: xtensor: Improve package style.
* gnu/packages/algebra.scm (xtensor): Shift fields order. Use G-expressions. Change-Id: Ica85f3e848a99eea45e07156eb659558fc6c0804
-rw-r--r--gnu/packages/algebra.scm30
1 files changed, 16 insertions, 14 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 748a9deb5e..310ca6589b 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -1164,22 +1164,24 @@ features, and more.")
(package
(name "xtensor")
(version "0.24.6")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/xtensor-stack/xtensor")
- (commit version)))
- (sha256
- (base32
- "0gf5m5p61981pv7yh5425lcv8dci948ri37hn1zlli7xg54x0g3i"))
- (file-name (git-file-name name version))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xtensor-stack/xtensor")
+ (commit version)))
+ (sha256
+ (base32 "0gf5m5p61981pv7yh5425lcv8dci948ri37hn1zlli7xg54x0g3i"))
+ (file-name (git-file-name name version))))
(build-system cmake-build-system)
- (native-inputs
- (list doctest googletest xtl))
(arguments
- `(#:configure-flags
- '("-DBUILD_TESTS=ON")
- #:test-target "xtest"))
+ (list
+ #:configure-flags #~(list "-DBUILD_TESTS=ON")
+ #:test-target "xtest"))
+ (native-inputs
+ (list doctest
+ googletest
+ xtl))
(home-page "https://xtensor.readthedocs.io/en/latest/")
(synopsis "C++ tensors with broadcasting and lazy computing")
(description "xtensor is a C++ library meant for numerical analysis with