summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-18 03:06:39 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:05 +0000
commit50a9000dc062b1194b9679063525f1ef4dc91a1f (patch)
tree5c0f0381e6e86e581c8a25ed7dfc41fd8200e7fc
parent84f2a1791534cd83bcae79a3e78b7becc8df3964 (diff)
gnu: Add go-modernc-org-mathutil.
* gnu/packages/golang-maths.scm (go-modernc-org-mathutil): New variable. Change-Id: Ifb27d5be71c98932f74e47cd56b854372f784da0
-rw-r--r--gnu/packages/golang-maths.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang-maths.scm b/gnu/packages/golang-maths.scm
index 8ecdf9948f..dc855b0a0c 100644
--- a/gnu/packages/golang-maths.scm
+++ b/gnu/packages/golang-maths.scm
@@ -278,6 +278,32 @@ distributions, and sampling; tools for function differentiation,integration,
and optimization; network creation and analysis")
(license license:expat)))
+(define-public go-modernc-org-mathutil
+ (package
+ (name "go-modernc-org-mathutil")
+ (version "1.6.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/cznic/mathutil")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0wafxarpfvys5p2wsamadkv8j54ahrv9dwmlba9xsxb85n4q9ywm"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "modernc.org/mathutil"))
+ (propagated-inputs (list go-github-com-remyoudompheng-bigfft))
+ (home-page "https://modernc.org/mathutil")
+ (synopsis
+ "Utilities supplemental to the Go standard @code{rand} and @code{math} packages")
+ (description
+ "Package mathutil provides utilities supplementing the standard
+@code{math} and @code{math/rand} packages.")
+ (license license:bsd-3)))
+
;;;
;;; Executables:
;;;