summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Bilke <[email protected]>2025-01-14 11:04:56 +0100
committerLudovic Courtès <[email protected]>2025-01-19 00:39:17 +0100
commit353145c0dab9266945ab005eede88593c586bf97 (patch)
tree3bd753601fc9643327ed2ccb39c4eba26b4115d1
parente327fc5cc48796beb232202af90033ed6b73bfd2 (diff)
gnu: Add tclap.
* gnu/packages/cpp.scm (tclap): New variable. Change-Id: I21e0eb623abe0b5add59647dec5606c706063e00 Signed-off-by: Ludovic Courtès <[email protected]>
-rw-r--r--gnu/packages/cpp.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index d3a8223a9c..3146cfea64 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -3531,3 +3531,34 @@ system to prevent more bugs.")
"Ada is a fast and spec-compliant URL parser written in C++.
Specification for URL parser can be found from the WHATWG website.")
(license license:gpl3+)))
+
+(define-public tclap
+ (package
+ (name "tclap")
+ (version "1.4.0-rc1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/" name "/" name "-" version
+ ".tar.bz2"))
+ (sha256
+ (base32 "1ii0gs965xagqfdwln9hd61y68352msybbq059grwspp51w8rq9k"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? parallel-tests? #:allow-other-keys)
+ (if tests?
+ (invoke "ctest" "-j"
+ (if parallel-tests?
+ (number->string (parallel-job-count))
+ "1"))
+ (format #t "test suite not run~%")))))))
+ (native-inputs (list python))
+ (home-page "https://sourceforge.net/p/tclap/discussion/")
+ (synopsis "Templatized Command Line Argument Parser")
+ (description
+ "This is a simple C++ library that facilitates parsing command line
+arguments in a type independent manner.")
+ (license license:expat)))