summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgemmaro <[email protected]>2025-01-22 20:47:19 +0530
committerHilton Chain <[email protected]>2025-01-25 00:45:07 +0800
commit32e31ef4286019be48d4b740f33f3127163abb70 (patch)
tree6090c4f12af42298ec4153e01438bed56748a678
parent9b98e4b0ee45fb712d815601645fb561a83b4e25 (diff)
gnu: font-gnu-unifont: Update to 16.0.02.
* gnu/packages/fonts.scm (font-gnu-unifont): Update to 16.0.02. [arguments] <#:phases>: Replace "/bin/sh" without the "-s" flag. Skip the thumbnails task. Co-authored-by: Ashvith Shetty <[email protected]> Change-Id: I56d1abb939d61e7c244bf0c117f0b5d13d053950 Signed-off-by: Hilton Chain <[email protected]> Modified-by: Hilton Chain <[email protected]>
-rw-r--r--gnu/packages/fonts.scm14
1 files changed, 10 insertions, 4 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 4dbbca69dc..8da0f6b9ec 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -55,11 +55,12 @@
;;; Copyright © 2023 Nicolas Graves <[email protected]>
;;; Copyright © 2023 Ahmad Draidi <[email protected]>
;;; Copyright © 2023 Arnaud Lechevallier <[email protected]>
-;;; Copyright © 2023 gemmaro <[email protected]>
+;;; Copyright © 2023, 2024 gemmaro <[email protected]>
;;; Copyright © 2023 Denis 'GNUtoo' Carikli <[email protected]>
;;; Copyright © 2023 chris <[email protected]>
;;; Copyright © 2023, 2024 Luis Felipe López Acevedo <[email protected]>
;;; Copyright © 2024 Christina O'Donnell <[email protected]>
+;;; Copyright © 2025 Ashvith Shetty <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1054,7 +1055,7 @@ for use at smaller text sizes")))
(define-public font-gnu-unifont
(package
(name "font-gnu-unifont")
- (version "15.1.05")
+ (version "16.0.02")
(source
(origin
(method url-fetch)
@@ -1064,7 +1065,7 @@ for use at smaller text sizes")))
(string-append "mirror://gnu/unifont/unifont-"
version "/unifont-" version ".tar.gz")))
(sha256
- (base32 "1yi33kxlgw7ds99za5bclh537sw8ggl94nrhhq7hwxaq8dgzaxfj"))
+ (base32 "0bd5mf3j7f0wggh9ss3a6rji62qwcfak37q6zb8lq9pjcf3yqa7i"))
(snippet
'(begin
(use-modules (guix build utils))
@@ -1086,7 +1087,12 @@ for use at smaller text sizes")))
(add-after 'unpack 'patch-source
(lambda _
(substitute* (find-files "." "Makefile")
- (("/bin/sh -s") (string-append (which "sh") " -s")))))
+ (("/bin/sh\\b") (which "sh")))
+ ;; Skip thumbnail generation as it requires ImageMagick and the generated
+ ;; thumbnails will not be installed.
+ (substitute* "font/Makefile"
+ (("^(compiled-files:.+)thumbnails(.+)" _ pre post)
+ (string-append pre post)))))
(replace 'install
(lambda* (#:key make-flags outputs #:allow-other-keys)
(let* ((ttf (string-append (assoc-ref outputs "out")