summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Hogan <[email protected]>2022-07-20 17:45:52 +0000
committerMarius Bakke <[email protected]>2022-07-23 23:02:23 +0200
commit2d44712b5b3a4ab5057835ec771fb36b99714db6 (patch)
tree457cd124475428edc913b1da9ca144f8e79a4933
parent62e7208017a1bf1faf723d9163f94374922f408f (diff)
gnu: python-typing-extensions: Update to 4.3.0.
* gnu/packages/python-xyz.scm (python-typing-extensions): Update to 4.3.0. [origin]: Use url-fetch. Signed-off-by: Marius Bakke <[email protected]>
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 4 insertions, 11 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b73d4e49d6..c593b6f6c1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21470,26 +21470,19 @@ with PEP 484 argument (and return) type annotations.")
(define-public python-typing-extensions
(package
(name "python-typing-extensions")
- (version "4.0.1")
+ (version "4.3.0")
(source (origin
- ;; The test script is missing from the PyPI archive.
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/python/typing")
- (commit version)))
- (file-name (git-file-name name version))
+ (method url-fetch)
+ (uri (pypi-uri "typing_extensions" version))
(sha256
(base32
- "0a35fh5wk9s538x0w3dz95y0avnhd2srzyv9s1a372711n8hdl4p"))))
+ "19n4l57qazwrbvxjrbxw2vvfyd0zbk8ivnwm4zmwfzzl69x6glp6"))))
(build-system python-build-system)
(arguments
(list
#:tests? #f ;requires Python's test module, not available in Guix
#:phases
#~(modify-phases %standard-phases
- (add-after 'unpack 'enter-source-directory
- (lambda _
- (chdir "typing_extensions")))
;; XXX: PEP 517 manual build copied from python-isort.
(replace 'build
(lambda _