summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-18 03:13:48 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:05 +0000
commit2ca21f101ecc34d5de5def9efc69443fd0148611 (patch)
treecf004e9c775ff66a389b69627446b75aa124c725
parent50a9000dc062b1194b9679063525f1ef4dc91a1f (diff)
gnu: Add go-modernc-org-memory.
* gnu/packages/golang-xyz.scm (go-modernc-org-memory): New variable. Change-Id: Id561b8c4a794cb5da1e784c22daec1f6f9004e89
-rw-r--r--gnu/packages/golang-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index ccc95408ec..a6c9091850 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -10796,6 +10796,30 @@ kubernetes-independent packages supplementing the
@url{https://pkg.go.dev/std#stdlib,Go standard libs}.")
(license license:asl2.0)))
+(define-public go-modernc-org-memory
+ (package
+ (name "go-modernc-org-memory")
+ (version "1.8.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/cznic/memory")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "066pzk0i1jxahialzp97ra0k0f191y1756sgppiw50zkpnpwzjxr"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "modernc.org/memory"))
+ (propagated-inputs
+ (list go-modernc-org-mathutil))
+ (home-page "https://gitlab.com/cznic/memory")
+ (synopsis "Memory allocator implementation")
+ (description "Package memory implements a memory allocator.")
+ (license license:bsd-3)))
+
(define-public go-mvdan-cc-editorconfig
(package
(name "go-mvdan-cc-editorconfig")