summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-06 19:06:52 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:47:38 +0000
commit01029576adf8c767f1f6068c4d7e5a6b875f7b0f (patch)
treef642bc683b6697df46d8e7fe3951ff2d7e3f800c
parentbf626173883976e1f23f7c9090cd22addecb73a3 (diff)
gnu: go-github-com-xdg-go-stringprep: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-xdg-go-stringprep): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: I0ef2efc4b8b3a5cc2e23ba365a78f653b7f9efc3
-rw-r--r--gnu/packages/golang-xyz.scm27
-rw-r--r--gnu/packages/golang.scm25
2 files changed, 27 insertions, 25 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 71e3c818be..b2d08c1ec3 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -12876,6 +12876,33 @@ edges and self-loops are not permitted.
@end itemize")
(license license:asl2.0)))
+(define-public go-github-com-xdg-go-stringprep
+ (package
+ (name "go-github-com-xdg-go-stringprep")
+ (version "1.0.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xdg-go/stringprep")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0xvaf2xiy34ra4xz75d6kylr29jv00dnyk14mh8kmq5692n8lqvb"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/xdg-go/stringprep"))
+ (propagated-inputs
+ (list go-golang-org-x-text))
+ (home-page "https://github.com/xdg-go/stringprep")
+ (synopsis "Go implementation of RFC-3454 stringprep and RFC-4013 SASLprep")
+ (description
+ "Package stringprep provides data tables and algorithms for RFC-3454,
+including errata. It also provides a profile for SASLprep as defined in
+RFC-4013.")
+ (license license:asl2.0)))
+
(define-public go-github-com-xhit-go-str2duration-v2
(package
(name "go-github-com-xhit-go-str2duration-v2")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 13a0007f65..43d2e29ba5 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3885,31 +3885,6 @@ temporal directories.")
@uref{freedesktop.org}.")
(license license:expat)))
-(define-public go-github-com-xdg-go-stringprep
- (package
- (name "go-github-com-xdg-go-stringprep")
- (version "1.0.4")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/xdg-go/stringprep")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0xvaf2xiy34ra4xz75d6kylr29jv00dnyk14mh8kmq5692n8lqvb"))))
- (build-system go-build-system)
- (arguments '(#:import-path "github.com/xdg-go/stringprep"))
- (propagated-inputs
- (list go-golang-org-x-text))
- (home-page "https://github.com/xdg-go/stringprep")
- (synopsis "Go implementation of RFC-3454 stringprep and RFC-4013 SASLprep")
- (description
- "Package stringprep provides data tables and algorithms for RFC-3454,
-including errata. It also provides a profile for SASLprep as defined in
-RFC-4013.")
- (license license:asl2.0)))
-
(define-public go-github-com-delthas-go-libnp
(let ((commit "0e45ece1f878f202fee2c74801e287804668f677"))
(package