summaryrefslogtreecommitdiff
path: root/gnu/packages/rust.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/rust.scm')
-rw-r--r--gnu/packages/rust.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 1be020a6bf..7d8d188b4a 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -207,10 +207,9 @@
;; Rust's own .so library files are not found in any RUNPATH, but
;; that doesn't seem to cause issues.
#:validate-runpath? #f
- ;; Most of the build is single-threaded. This also improves the
- ;; build time on machines with "only" 8GB of RAM.
- ;; ppc64le regularly sees race conditions between various dependant crates.
- #:parallel-build? ,(target-x86-64?)
+ ;; We currently see race conditions between various dependant crates.
+ ;; TODO: Re-evaluate after moving to a more recent mrustc.
+ #:parallel-build? #f
#:make-flags
(list ,(string-append "RUSTC_TARGET="
(platform-rust-target