summaryrefslogtreecommitdiff
path: root/gnu/packages/rust.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-12-14 20:23:43 +0200
committerEfraim Flashner <efraim@flashner.co.il>2025-01-06 12:14:57 +0200
commitd3185f33cd1e96a68856f36be94bcda38dc2d51c (patch)
treeb759b14cf7eab9e0bb7deba5e580e8e1217d961f /gnu/packages/rust.scm
parent398896690461b6b621f8cfa272151167c5e40a39 (diff)
gnu: rust-bootstrap: Don't use parallel-build.
* gnu/packages/rust.scm (rust-bootstrap)[arguments]: Change parallel-build? to be false on all architectures. Change-Id: I36aa984f9d47e01d35270423dbf44d57182854f0
Diffstat (limited to 'gnu/packages/rust.scm')
-rw-r--r--gnu/packages/rust.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 1be020a6bf..7d8d188b4a 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -207,10 +207,9 @@
;; Rust's own .so library files are not found in any RUNPATH, but
;; that doesn't seem to cause issues.
#:validate-runpath? #f
- ;; Most of the build is single-threaded. This also improves the
- ;; build time on machines with "only" 8GB of RAM.
- ;; ppc64le regularly sees race conditions between various dependant crates.
- #:parallel-build? ,(target-x86-64?)
+ ;; We currently see race conditions between various dependant crates.
+ ;; TODO: Re-evaluate after moving to a more recent mrustc.
+ #:parallel-build? #f
#:make-flags
(list ,(string-append "RUSTC_TARGET="
(platform-rust-target