summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/python-pycrypto-time-clock.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/python-pycrypto-time-clock.patch')
-rw-r--r--gnu/packages/patches/python-pycrypto-time-clock.patch23
1 files changed, 0 insertions, 23 deletions
diff --git a/gnu/packages/patches/python-pycrypto-time-clock.patch b/gnu/packages/patches/python-pycrypto-time-clock.patch
deleted file mode 100644
index 9b7a8232a2..0000000000
--- a/gnu/packages/patches/python-pycrypto-time-clock.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-Drop use of the deprecated time.clock which was removed in Python 3.8.
-
-Adapted from upstream pull request:
-
-https://github.com/dlitz/pycrypto/pull/296
-
-diff --git a/lib/Crypto/Random/_UserFriendlyRNG.py b/lib/Crypto/Random/_UserFriendlyRNG.py
---- a/lib/Crypto/Random/_UserFriendlyRNG.py
-+++ b/lib/Crypto/Random/_UserFriendlyRNG.py
-@@ -73,8 +73,11 @@ class _EntropyCollector(object):
- t = time.time()
- self._time_es.feed(struct.pack("@I", int(2**30 * (t - floor(t)))))
-
-- # Add the fractional part of time.clock()
-- t = time.clock()
-+ # Add the fractional part of time.process_time()
-+ try:
-+ t = time.process_time()
-+ except AttributeError:
-+ t = time.clock()
- self._clock_es.feed(struct.pack("@I", int(2**30 * (t - floor(t)))))
-
-