summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/python-pycrypto-time-clock.patch
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <[email protected]>2023-10-22 02:00:00 +0200
committerTobias Geerinckx-Rice <[email protected]>2023-10-22 02:00:00 +0200
commitd461dd81cd688ddd63892204a19b3456810352e8 (patch)
treef751034955658f8b080b60e96d25d3febfed2d86 /gnu/packages/patches/python-pycrypto-time-clock.patch
parentaabfddbe8bc16fa82067e88e7d79c8c1bc802414 (diff)
gnu: Remove left-over python-pycrypto patches.
This follows up on commit a55e18f17cc82a01c11d03bdfb693c62cb068d5c. Change-Id: If61e46da1dc4f352b362ad3db42859322846984b
Diffstat (limited to 'gnu/packages/patches/python-pycrypto-time-clock.patch')
-rw-r--r--gnu/packages/patches/python-pycrypto-time-clock.patch23
1 files changed, 0 insertions, 23 deletions
diff --git a/gnu/packages/patches/python-pycrypto-time-clock.patch b/gnu/packages/patches/python-pycrypto-time-clock.patch
deleted file mode 100644
index 9b7a8232a2..0000000000
--- a/gnu/packages/patches/python-pycrypto-time-clock.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-Drop use of the deprecated time.clock which was removed in Python 3.8.
-
-Adapted from upstream pull request:
-
-https://github.com/dlitz/pycrypto/pull/296
-
-diff --git a/lib/Crypto/Random/_UserFriendlyRNG.py b/lib/Crypto/Random/_UserFriendlyRNG.py
---- a/lib/Crypto/Random/_UserFriendlyRNG.py
-+++ b/lib/Crypto/Random/_UserFriendlyRNG.py
-@@ -73,8 +73,11 @@ class _EntropyCollector(object):
- t = time.time()
- self._time_es.feed(struct.pack("@I", int(2**30 * (t - floor(t)))))
-
-- # Add the fractional part of time.clock()
-- t = time.clock()
-+ # Add the fractional part of time.process_time()
-+ try:
-+ t = time.process_time()
-+ except AttributeError:
-+ t = time.clock()
- self._clock_es.feed(struct.pack("@I", int(2**30 * (t - floor(t)))))
-
-