summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorVagrant Cascadian <[email protected]>2025-03-02 12:02:19 -0800
committerVagrant Cascadian <[email protected]>2025-03-09 14:45:44 -0700
commite37d407e6c17d36c31b71a077c7fd505f2be5095 (patch)
tree92b34c8967035df3ef68e05f9cf07c15987aed50 /gnu
parent3aed6ee07bd0d22cd6cf897eada7ea3b95f6adf5 (diff)
gnu: u-boot: Update to 2025.01.
* gnu/packages/bootloaders.scm (u-boot): Update to 2025.01. (u-boot-sandbox): Disable MBEDTLS_LIB.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bootloaders.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 153e5ede0b..fcdd3abbba 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -757,7 +757,7 @@ tree binary files. These are board description files used by Linux and BSD.")
(define u-boot
(package
(name "u-boot")
- (version "2024.10")
+ (version "2025.01")
(source
(origin
(method git-fetch)
@@ -766,7 +766,7 @@ tree binary files. These are board description files used by Linux and BSD.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0yrhb0izihv47p781dc4cp0znc5g225ayl7anz23c6jdrmfbpz2h"))
+ (base32 "1i1v86bnixh8hyqbwwr5iwdnnadmg2fqxw9g526fvclsbvl8lz0v"))
(patches (search-patches "u-boot-allow-disabling-openssl.patch"
"u-boot-rockchip-inno-usb.patch"))))
(build-system gnu-build-system)
@@ -1343,7 +1343,7 @@ partition."))
;; These disabled features require OpenSSL, which is
;; incompatible with the GPLv2-only parts of U-boot.
#:configs (map (cut string-append "# CONFIG_" <> " is not set")
- '("FIT_CIPHER"))
+ '("FIT_CIPHER" "MBEDTLS_LIB"))
#:append-description
"The sandbox configuration of U-Boot provides a @command{u-boot}
command that runs as a normal user space application. It can be used to